Xero Service Issue

Incident Report for Elixir

Resolved

This incident has been resolved.
Posted May 11, 2026 - 13:17 NZST

Monitoring

We are currently experiencing issues caused by an ongoing incident with Xero. Users may experience:

- Slow invoicing in Elixir
- Inability to mark items as paid
- Xero Account connections disconnecting when invoicing or marking invoices as paid
- Xero Account connections disconnecting repeatedly even after re-establishing the connection

Xero is aware of the issue and is continuing to investigate. Please refer to the Xero Status Page for further updates.
https://status.xero.com/
Posted May 11, 2026 - 12:33 NZST
This incident affected: Xero Ltd - API Accounting API.